summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-27 07:51:15 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-27 09:13:12 +0200
commit5a32cf169e4c84dfde402089523e09f60e494aa1 (patch)
treecd4028b6b8b1cb602b672c48e66580a975120f31 /dev-ruby/io-wait
parentdev-ruby/posix-spawn: cleanup (diff)
downloadgentoo-5a32cf169e4c84dfde402089523e09f60e494aa1.tar.gz
gentoo-5a32cf169e4c84dfde402089523e09f60e494aa1.tar.bz2
gentoo-5a32cf169e4c84dfde402089523e09f60e494aa1.zip
dev-ruby/io-wait: enable ruby31, fix test setup
Closes: https://bugs.gentoo.org/833262 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/io-wait')
-rw-r--r--dev-ruby/io-wait/io-wait-0.2.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ruby/io-wait/io-wait-0.2.1.ebuild b/dev-ruby/io-wait/io-wait-0.2.1.ebuild
index 9a4ccbcf463c..4def09c942da 100644
--- a/dev-ruby/io-wait/io-wait-0.2.1.ebuild
+++ b/dev-ruby/io-wait/io-wait-0.2.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_BINWRAP=""
RUBY_FAKEGEM_EXTENSIONS="ext/io/wait/extconf.rb"
@@ -26,3 +26,7 @@ all_ruby_prepare() {
-i ${RUBY_FAKEGEM_GEMSPEC} || die
sed -e '/task :test/ s:^:#:' -i Rakefile || die
}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}