summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-10-20 07:13:06 +0200
committerHans de Graaff <graaff@gentoo.org>2018-10-20 07:13:06 +0200
commit8dfd6303c5a501f62096c14e8ca05e307a0bf6e2 (patch)
tree70a4234c6b13701070017e7629a7b8973879fe73 /dev-ruby/itextomml/itextomml-1.5.8.ebuild
parentapp-admin/ansible: 2.6.6 bump (diff)
downloadgentoo-8dfd6303c5a501f62096c14e8ca05e307a0bf6e2.tar.gz
gentoo-8dfd6303c5a501f62096c14e8ca05e307a0bf6e2.tar.bz2
gentoo-8dfd6303c5a501f62096c14e8ca05e307a0bf6e2.zip
dev-ruby/itextomml: add 1.5.8
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/itextomml/itextomml-1.5.8.ebuild')
-rw-r--r--dev-ruby/itextomml/itextomml-1.5.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/itextomml/itextomml-1.5.8.ebuild b/dev-ruby/itextomml/itextomml-1.5.8.ebuild
new file mode 100644
index 000000000000..4e99a8e16369
--- /dev/null
+++ b/dev-ruby/itextomml/itextomml-1.5.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Native Ruby bindings to itex2MML, which converts itex equations to MathML"
+HOMEPAGE="https://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+#Tests don't fail here
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/itex2MML$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/test_itextomml.rb || die
+}