summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-11-29 08:27:29 +0100
committerHans de Graaff <graaff@gentoo.org>2015-11-29 08:29:36 +0100
commit9fd26f370ae1d4ff7eb929bc5cff702cdced86ad (patch)
treeb936e652450cc05db4dc7a083da277509745787b /dev-ruby/listen/listen-3.0.5.ebuild
parentdev-ruby/dbf: add 3.0.1 (diff)
downloadgentoo-9fd26f370ae1d4ff7eb929bc5cff702cdced86ad.tar.gz
gentoo-9fd26f370ae1d4ff7eb929bc5cff702cdced86ad.tar.bz2
gentoo-9fd26f370ae1d4ff7eb929bc5cff702cdced86ad.zip
dev-ruby/listen: add 3.0.5
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/listen/listen-3.0.5.ebuild')
-rw-r--r--dev-ruby/listen/listen-3.0.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/listen/listen-3.0.5.ebuild b/dev-ruby/listen/listen-3.0.5.ebuild
new file mode 100644
index 000000000000..8b98721ce8ec
--- /dev/null
+++ b/dev-ruby/listen/listen-3.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Listens to file modifications and notifies you about the changes"
+HOMEPAGE="https://github.com/guard/listen"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+# Block on other packages trying to install a /usr/bin/listen
+RDEPEND+="!!media-sound/listen !!media-radio/ax25 !!<dev-ruby/listen-2.8.6-r1:2"
+
+ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
+
+ruby_add_bdepend "test? ( dev-ruby/thor )"
+
+all_ruby_prepare() {
+ rm -f Gemfile || die
+ sed -i -e "/git/,+3d" -e "/rb-fsevent/d" ${PN}.gemspec || die
+ rm -rf spec/lib/listen/adapter/darwin_spec.rb || die
+}
+
+each_ruby_prepare() {
+ mkdir spec/.fixtures || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec
+ rm -rf spec/.fixtures || die
+}