summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-26 19:30:38 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-27 07:19:37 +0200
commit87af93b00ffdd8a80e9bb706b109c2cf7c0f8fb7 (patch)
tree16868c49fd605253b63533993c747675513e45f0 /dev-ruby/listen/listen-3.0.8.ebuild
parentnet-analyzer/ssldump: Fix HOMEPAGE/SRC_URI (bug #589784 by Jonas Stein), remo... (diff)
downloadgentoo-87af93b00ffdd8a80e9bb706b109c2cf7c0f8fb7.tar.gz
gentoo-87af93b00ffdd8a80e9bb706b109c2cf7c0f8fb7.tar.bz2
gentoo-87af93b00ffdd8a80e9bb706b109c2cf7c0f8fb7.zip
dev-ruby/listen: add 3.0.8
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/listen/listen-3.0.8.ebuild')
-rw-r--r--dev-ruby/listen/listen-3.0.8.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/listen/listen-3.0.8.ebuild b/dev-ruby/listen/listen-3.0.8.ebuild
new file mode 100644
index 000000000000..a8f1dd37bf80
--- /dev/null
+++ b/dev-ruby/listen/listen-3.0.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Listens to file modifications and notifies you about the changes"
+HOMEPAGE="https://github.com/guard/listen"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~ppc64 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+# Block on other packages trying to install a /usr/bin/listen
+RDEPEND+="!!media-sound/listen !!media-radio/ax25 !!<dev-ruby/listen-2.8.6-r1:2"
+
+ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.7"
+
+ruby_add_bdepend "test? ( dev-ruby/thor )"
+
+all_ruby_prepare() {
+ rm -f Gemfile || die
+
+ # Avoid dependency on rb-fsevent since we do not support Darwin
+ sed -i -e "/git/,+3d" -e "/rb-fsevent/d" ${PN}.gemspec || die
+ rm -rf spec/lib/listen/adapter/darwin_spec.rb || die
+ # Try Linux first since we now we use Linux and since the Darwin
+ # adapter now throws errors when rb-fsevent is not present.
+ sed -i -e 's/Darwin, Linux/Linux, Darwin/' lib/listen/adapter.rb || die
+}
+
+each_ruby_prepare() {
+ mkdir spec/.fixtures || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec
+ rm -rf spec/.fixtures || die
+}