summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-05 08:39:15 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-05 08:50:57 +0100
commit16f55c32975b3bc66b11c1ae61820d9618e4bf3a (patch)
treefbc39c3de42d5a7d13d63700af14e00309f90b2e /dev-ruby/localhost
parentdev-python/tempest: add 29.1.0, partial enable tests (diff)
downloadgentoo-16f55c32975b3bc66b11c1ae61820d9618e4bf3a.tar.gz
gentoo-16f55c32975b3bc66b11c1ae61820d9618e4bf3a.tar.bz2
gentoo-16f55c32975b3bc66b11c1ae61820d9618e4bf3a.zip
dev-ruby/localhost: import of 1.1.9
New test dependency for www-servers/puma. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/localhost')
-rw-r--r--dev-ruby/localhost/Manifest1
-rw-r--r--dev-ruby/localhost/localhost-1.1.9.ebuild31
-rw-r--r--dev-ruby/localhost/metadata.xml8
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/localhost/Manifest b/dev-ruby/localhost/Manifest
new file mode 100644
index 000000000000..ed63740a7d32
--- /dev/null
+++ b/dev-ruby/localhost/Manifest
@@ -0,0 +1 @@
+DIST localhost-1.1.9.tar.gz 2125545 BLAKE2B 5843b3857a11d9f56412f67cb15e424332b07cf81a29ae0a05a3ff20c6f06af56f6a02d8315f97c2d57fe76f7359c737cf19f116868ff532ac083070430fa22e SHA512 d46fd016957fd34309d50488dc61f23e9d47a5a6bfdeda5c049f6ffc112c13cd21394ada3e15c56f14913cba6ab503f60e32237431f7ff824fbbab8cd8a2d746
diff --git a/dev-ruby/localhost/localhost-1.1.9.ebuild b/dev-ruby/localhost/localhost-1.1.9.ebuild
new file mode 100644
index 000000000000..c0bfad9d596c
--- /dev/null
+++ b/dev-ruby/localhost/localhost-1.1.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="localhost.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manage a local CA for self-signed localhost development servers"
+HOMEPAGE="https://github.com/socketry/localhost"
+SRC_URI="https://github.com/socketry/localhost/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+# Skip tests for now since they require a lot of
+# dependencies and this package blocks a security bug.
+RESTRICT="test"
+
+#ruby_add_bdepend "test? ( dev-ruby/async-rspec ) "
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/localhost/metadata.xml b/dev-ruby/localhost/metadata.xml
new file mode 100644
index 000000000000..658c72b1920d
--- /dev/null
+++ b/dev-ruby/localhost/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>