summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/mechanize
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/mechanize')
-rw-r--r--dev-ruby/mechanize/Manifest1
-rw-r--r--dev-ruby/mechanize/files/mechanize-2.6.0-libxml290.patch34
-rw-r--r--dev-ruby/mechanize/mechanize-2.7.3-r1.ebuild39
-rw-r--r--dev-ruby/mechanize/mechanize-2.7.3.ebuild39
-rw-r--r--dev-ruby/mechanize/metadata.xml8
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-ruby/mechanize/Manifest b/dev-ruby/mechanize/Manifest
new file mode 100644
index 000000000000..598b42cc1927
--- /dev/null
+++ b/dev-ruby/mechanize/Manifest
@@ -0,0 +1 @@
+DIST mechanize-2.7.3.gem 133120 SHA256 3de7f3c2799be07b2788c8226e73cf9120a04ae79602c5bab2de6287e4575302 SHA512 5a06f1e7a1c97f985f3011358061c631bcc69e3092082959f738670c9491f734bc6dbbca321018fa484ee493f2f251b8af0cf17602fe381d491ff3e18663f2eb WHIRLPOOL 661869f23fd4f0a60a9a58ba35fd02cd51a65af79c66f8ab04d18498feb20f200d2959351ff44bcb4385f0c947e3b47e1b3e046735021d60d502256df8c63f98
diff --git a/dev-ruby/mechanize/files/mechanize-2.6.0-libxml290.patch b/dev-ruby/mechanize/files/mechanize-2.6.0-libxml290.patch
new file mode 100644
index 000000000000..0b5409f582bb
--- /dev/null
+++ b/dev-ruby/mechanize/files/mechanize-2.6.0-libxml290.patch
@@ -0,0 +1,34 @@
+commit 43f3b631484a2c0178e6699584471dedd598eca3
+Author: Lee Jarvis <ljjarvis@gmail.com>
+Date: Mon May 6 19:39:25 2013 +0100
+
+ Ensure we prefix xpath with // for searching entire document
+
+ Tests prior to this commit passed because libxml2 was not so
+ strict. Since upgrading to 2.9.0 this issue has been revealed.
+ The former test should have been written with this in mind.
+
+ Steps to reproduce (on OSX with Homebrew installed):
+
+ gem uninstall nokogiri
+ brew install libxml2
+ LDFLAGS="-L/usr/local/opt/libxml2/lib" \
+ CPPFLAGS="-I/usr/local/opt/libxml2/include" \
+ gem install nokogiri
+
+ closes #308
+
+diff --git a/test/test_mechanize_xml_file.rb b/test/test_mechanize_xml_file.rb
+index 58eb67c..bbe486c 100644
+--- a/test/test_mechanize_xml_file.rb
++++ b/test/test_mechanize_xml_file.rb
+@@ -23,7 +23,7 @@ class TestMechanizeXmlFile < Mechanize::TestCase
+ end
+
+ def test_at
+- assert_equal 'Perl', @xml.at('language[2]').text
++ assert_equal 'Perl', @xml.at('//language[2]').text
+ end
+
+ end
+\ No newline at end of file
diff --git a/dev-ruby/mechanize/mechanize-2.7.3-r1.ebuild b/dev-ruby/mechanize/mechanize-2.7.3-r1.ebuild
new file mode 100644
index 000000000000..608d1248c13c
--- /dev/null
+++ b/dev-ruby/mechanize/mechanize-2.7.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc EXAMPLES.rdoc GUIDE.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library used for automating interaction with websites"
+HOMEPAGE="https://github.com/sparklemotion/mechanize"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-3.7
+ test? ( dev-ruby/minitest:5 )"
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4-r1
+ >=dev-ruby/net-http-digest_auth-1.1.1
+ >=dev-ruby/net-http-persistent-2.5.2
+ >=dev-ruby/ntlm-http-0.1.1
+ >=dev-ruby/webrobots-0.0.9
+ >=dev-ruby/http-cookie-1.0.2
+ >=dev-ruby/mime-types-2.0
+ >=dev-ruby/domain_name-0.5.1"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}
diff --git a/dev-ruby/mechanize/mechanize-2.7.3.ebuild b/dev-ruby/mechanize/mechanize-2.7.3.ebuild
new file mode 100644
index 000000000000..14201f2aa866
--- /dev/null
+++ b/dev-ruby/mechanize/mechanize-2.7.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc EXAMPLES.rdoc GUIDE.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library used for automating interaction with websites"
+HOMEPAGE="https://github.com/sparklemotion/mechanize"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-3.7
+ test? ( dev-ruby/minitest:5 )"
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4-r1
+ >=dev-ruby/net-http-digest_auth-1.1.1
+ >=dev-ruby/net-http-persistent-2.5.2
+ >=dev-ruby/ntlm-http-0.1.1
+ >=dev-ruby/webrobots-0.0.9
+ >=dev-ruby/http-cookie-1.0.2
+ >=dev-ruby/mime-types-2.0
+ >=dev-ruby/domain_name-0.5.1"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}
diff --git a/dev-ruby/mechanize/metadata.xml b/dev-ruby/mechanize/metadata.xml
new file mode 100644
index 000000000000..b6474c747797
--- /dev/null
+++ b/dev-ruby/mechanize/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">sparklemotion/mechanize</remote-id>
+ </upstream>
+</pkgmetadata>