summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-11-21 10:57:03 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-11-21 13:20:47 -0500
commit54f1cbd43e29222a146bdccaa3e744e83f522b41 (patch)
tree5b989dd1f97156f859d1300693a5dd0c1f228711 /dev-ruby/metasploit-payloads/metasploit-payloads-1.3.53.ebuild
parentdev-ruby/metasploit-credential: bump, x86 (diff)
downloadgentoo-54f1cbd43e29222a146bdccaa3e744e83f522b41.tar.gz
gentoo-54f1cbd43e29222a146bdccaa3e744e83f522b41.tar.bz2
gentoo-54f1cbd43e29222a146bdccaa3e744e83f522b41.zip
dev-ruby/metasploit-payloads: bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-ruby/metasploit-payloads/metasploit-payloads-1.3.53.ebuild')
-rw-r--r--dev-ruby/metasploit-payloads/metasploit-payloads-1.3.53.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/metasploit-payloads/metasploit-payloads-1.3.53.ebuild b/dev-ruby/metasploit-payloads/metasploit-payloads-1.3.53.ebuild
new file mode 100644
index 000000000000..66b34890ecde
--- /dev/null
+++ b/dev-ruby/metasploit-payloads/metasploit-payloads-1.3.53.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compiled binaries for Metasploit's Meterpreter"
+HOMEPAGE="https://rubygems.org/gems/metasploit-payloads"
+
+LICENSE="BSD"
+
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#no tests
+RESTRICT="test strip"
+
+QA_PREBUILT="
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/msflinker_linux_x86.bin
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_sniffer.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_networkpug.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_stdapi.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/armeabi/libndkstager.so
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/mips/libndkstager.so
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/x86/libndkstager.so
+ "
+
+src_install() {
+ ruby-ng_src_install
+ #tell revdep-rebuild to ignore binaries meant for the target
+ dodir /etc/revdep-rebuild
+ cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-${PN}-${SLOT} || die
+ #These dirs contain prebuilt binaries for running on the TARGET not the HOST
+ SEARCH_DIRS_MASK="/usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs"
+ EOF
+}