summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-19 10:22:10 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-19 13:00:45 +0100
commit20404c54e3c08d440c7652c534a45750e8dfccb9 (patch)
treec1c01a23b78db8a406959afb531a89227a192169 /dev-ruby/minitest-around
parentdev-util/cucumber: add ruby30 (diff)
downloadgentoo-20404c54e3c08d440c7652c534a45750e8dfccb9.tar.gz
gentoo-20404c54e3c08d440c7652c534a45750e8dfccb9.tar.bz2
gentoo-20404c54e3c08d440c7652c534a45750e8dfccb9.zip
dev-ruby/minitest-around: add ruby30; EAPI 8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/minitest-around')
-rw-r--r--dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..7036fe227017
--- /dev/null
+++ b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Alternative for setup/teardown dance"
+HOMEPAGE="https://github.com/splattael/minitest-around"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/minitest:5"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-util/cucumber )"
+
+all_ruby_prepare() {
+ sed -i -e '/bump/ s:^:#:' \
+ -e '/ls-files/d' \
+ -e '/cucumber/ s/,.*$//' minitest-around.gemspec Rakefile || die
+}
+
+each_ruby_test() {
+ for f in test/*_{test,spec}.rb ; do
+ ${RUBY} -S rake test:isolated TEST="${f}" || die
+ done
+}