summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/multipart-post
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/multipart-post')
-rw-r--r--dev-ruby/multipart-post/Manifest1
-rw-r--r--dev-ruby/multipart-post/files/multibyte.txt1
-rw-r--r--dev-ruby/multipart-post/metadata.xml8
-rw-r--r--dev-ruby/multipart-post/multipart-post-2.0.0.ebuild26
4 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/multipart-post/Manifest b/dev-ruby/multipart-post/Manifest
new file mode 100644
index 000000000000..5da28695dd53
--- /dev/null
+++ b/dev-ruby/multipart-post/Manifest
@@ -0,0 +1 @@
+DIST multipart-post-2.0.0.gem 11264 SHA256 3dc44e50d3df3d42da2b86272c568fd7b75c928d8af3cc5f9834e2e5d9586026 SHA512 4f48c815d82c139986f419cdb12efd2f3792f2ef0b2277b75533c8ddad17cc6a8c187deddadc82d29c9f7f8337fcc9ad23c40eb72053ac933911ec1457b01c18 WHIRLPOOL ffc790649e0c2514e216f52e50fceda00f7fa48561a18f58822c917445612f7d376f910b9adee4bb05a13d66268b521142c5d13e298289ba575df9d1adb5aaff
diff --git a/dev-ruby/multipart-post/files/multibyte.txt b/dev-ruby/multipart-post/files/multibyte.txt
new file mode 100644
index 000000000000..24a84b0457db
--- /dev/null
+++ b/dev-ruby/multipart-post/files/multibyte.txt
@@ -0,0 +1 @@
+ファイル
diff --git a/dev-ruby/multipart-post/metadata.xml b/dev-ruby/multipart-post/metadata.xml
new file mode 100644
index 000000000000..148a4c6e85da
--- /dev/null
+++ b/dev-ruby/multipart-post/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">nicksieger/multipart-post</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/multipart-post/multipart-post-2.0.0.ebuild b/dev-ruby/multipart-post/multipart-post-2.0.0.ebuild
new file mode 100644
index 000000000000..bbe7f2f332eb
--- /dev/null
+++ b/dev-ruby/multipart-post/multipart-post-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Adds a streamy multipart form post capability to Net::HTTP"
+HOMEPAGE="http://github.com/nicksieger/multipart-post"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+each_ruby_test() {
+ ${RUBY} -S testrb -Ilib test || die "Tests failed."
+}