summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/naught
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/naught')
-rw-r--r--dev-ruby/naught/Manifest1
-rw-r--r--dev-ruby/naught/metadata.xml8
-rw-r--r--dev-ruby/naught/naught-1.0.0.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/naught/Manifest b/dev-ruby/naught/Manifest
new file mode 100644
index 000000000000..3a440d05b251
--- /dev/null
+++ b/dev-ruby/naught/Manifest
@@ -0,0 +1 @@
+DIST naught-1.0.0.gem 18432 SHA256 edc710f133e8455deb413ffc5f0ca9da586f04a2b716cfbf65d324360c84a612 SHA512 2a68358a50548d0d1dcc85a93246fb79e95ca4aef99376f80d7ae46ff6262d4adc764da3e8eb8df2d5410091fabf1e641f47781e7c30fd3dac58acf0e35f4626 WHIRLPOOL 71d40cb2b7748991d29dc162e9173b5c26f28e95da84308677258b4d688e9e8729e46b9e2aa9efa3246841beb8ce48d7a389b4cc4413134c026cde2534592d4d
diff --git a/dev-ruby/naught/metadata.xml b/dev-ruby/naught/metadata.xml
new file mode 100644
index 000000000000..3691a56fa532
--- /dev/null
+++ b/dev-ruby/naught/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">avdi/naught</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/naught/naught-1.0.0.ebuild b/dev-ruby/naught/naught-1.0.0.ebuild
new file mode 100644
index 000000000000..6f00286ff1d7
--- /dev/null
+++ b/dev-ruby/naught/naught-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building Null Objects in Ruby"
+HOMEPAGE="https://github.com/avdi/naught"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/^if/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}