summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-01-31 07:58:38 +0100
committerHans de Graaff <graaff@gentoo.org>2019-01-31 08:35:09 +0100
commit7980cddf0e7042b6fcfdcdd1361e5c99da6c022c (patch)
tree2f452c8be106df83e6e062e152f4f98f6a302486 /dev-ruby/net-http-pipeline
parentdev-ruby/netrc: add ruby26 (diff)
downloadgentoo-7980cddf0e7042b6fcfdcdd1361e5c99da6c022c.tar.gz
gentoo-7980cddf0e7042b6fcfdcdd1361e5c99da6c022c.tar.bz2
gentoo-7980cddf0e7042b6fcfdcdd1361e5c99da6c022c.zip
dev-ruby/net-http-pipeline: add ruby26
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/net-http-pipeline')
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
index a8ecd68283ff..0f4ded070376 100644
--- a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
+++ b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
inherit ruby-fakegem
@@ -18,6 +18,9 @@ IUSE=""
RUBY_PATCHES=( ${PN}-accept-encoding.patch )
ruby_add_bdepend "
- dev-ruby/hoe
test? ( dev-ruby/minitest )
"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}