summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-25 08:46:55 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-25 10:09:50 +0100
commite1fb94b2b291ccf47ab5d3fe3310df19412fb80f (patch)
treee91a3d2c38fa3e47a4fa64d1f61f35562be2b7a5 /dev-ruby/net-http-pipeline
parentdev-ruby/net-ssh-gateway: cleanup (diff)
downloadgentoo-e1fb94b2b291ccf47ab5d3fe3310df19412fb80f.tar.gz
gentoo-e1fb94b2b291ccf47ab5d3fe3310df19412fb80f.tar.bz2
gentoo-e1fb94b2b291ccf47ab5d3fe3310df19412fb80f.zip
dev-ruby/net-http-pipeline: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/net-http-pipeline')
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1-r1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..a4b32a23797d
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An HTTP/1.1 pipelining implementation atop Net::HTTP"
+HOMEPAGE="http://docs.seattlerb.org/net-http-pipeline/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ test? ( dev-ruby/minitest )
+"
+
+all_ruby_prepare() {
+ eapply -p0 "${FILESDIR}/${PN}-accept-encoding.patch"
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}