summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2018-01-22 08:59:55 +0100
committerHans de Graaff <graaff@gentoo.org>2018-03-03 08:10:47 +0100
commitbd4c29444ea46119e70dcc842b5f4b0630167ccf (patch)
tree98456e0e8cfe4766f9698b52d281233a8aca0975 /dev-ruby/net-scp/net-scp-1.2.1-r1.ebuild
parentdev-ruby/selenium-webdriver: add 3.10.0 (diff)
downloadgentoo-bd4c29444ea46119e70dcc842b5f4b0630167ccf.tar.gz
gentoo-bd4c29444ea46119e70dcc842b5f4b0630167ccf.tar.bz2
gentoo-bd4c29444ea46119e70dcc842b5f4b0630167ccf.zip
dev-ruby/net-scp: add ruby version 2.4
This ebuild also corrects the tests to pass with net-ssh-4.0 or later. The patches are taken from https://anonscm.debian.org/cgit/pkg-ruby-extras/ruby-net-sftp.git/ And from git commits following version 1.2.1 in upstream. Bug: https://bugs.gentoo.org/643990 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/net-scp/net-scp-1.2.1-r1.ebuild')
-rw-r--r--dev-ruby/net-scp/net-scp-1.2.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/net-scp/net-scp-1.2.1-r1.ebuild b/dev-ruby/net-scp/net-scp-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..2d152002dd28
--- /dev/null
+++ b/dev-ruby/net-scp/net-scp-1.2.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby implementation of the SCP client protocol"
+HOMEPAGE="https://github.com/net-ssh/net-scp"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_PATCHES=(
+ ${P}-raise-correct-errors.patch
+ ${P}-fix-common.path
+ ${P}-fix-download_test.patch
+ ${P}-fix-download_test_2.patch
+ ${P}-fix-download_test_3.patch
+ ${P}-fix-upload_tests.patch
+ ${P}-raise-correct-errors-net-ssh-4.0-compat.patch
+ )
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/net-ssh-4.0:4 )
+ test? (
+ >=dev-ruby/net-ssh-4.0:4
+ dev-ruby/mocha
+ )"
+
+ruby_add_rdepend ">=dev-ruby/net-ssh-4.0:4"
+
+all_ruby_prepare() {
+ sed -i -e 's/>= 2.0.0/~> 2.0/' test/common.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_all.rb || die
+}