summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/net-sftp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/net-sftp')
-rw-r--r--dev-ruby/net-sftp/Manifest1
-rw-r--r--dev-ruby/net-sftp/metadata.xml8
-rw-r--r--dev-ruby/net-sftp/net-sftp-2.1.2-r1.ebuild25
-rw-r--r--dev-ruby/net-sftp/net-sftp-2.1.2-r2.ebuild25
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/net-sftp/Manifest b/dev-ruby/net-sftp/Manifest
new file mode 100644
index 000000000000..92e24b5346a4
--- /dev/null
+++ b/dev-ruby/net-sftp/Manifest
@@ -0,0 +1 @@
+DIST net-sftp-2.1.2.gem 67584 SHA256 3e70b8130b1c86039b0847aeb088a2254df49053023546a5923e5763c923c710 SHA512 126a9537a4ac45150096db4d46ad19e0d8a1833fef3733a1b66ff01463c0d109415f0ef807706ff88be8c5c1395bbd4620e529f06e3c9f746a4ed6ec2cb7d18d WHIRLPOOL fcb0e6ac8d20aaf7f66643d5e15bf1dfd9a41a281048511a12090bf7ba54f7452b6d67ddaf84af2112e552c7833917eb70cf39285501c0bcfccd6c587924ebf6
diff --git a/dev-ruby/net-sftp/metadata.xml b/dev-ruby/net-sftp/metadata.xml
new file mode 100644
index 000000000000..64690fa25a6c
--- /dev/null
+++ b/dev-ruby/net-sftp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">net-ssh/net-sftp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-sftp/net-sftp-2.1.2-r1.ebuild b/dev-ruby/net-sftp/net-sftp-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..8acaf7de0df5
--- /dev/null
+++ b/dev-ruby/net-sftp/net-sftp-2.1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SFTP in pure Ruby"
+HOMEPAGE="http://net-ssh.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.13
+ )"
diff --git a/dev-ruby/net-sftp/net-sftp-2.1.2-r2.ebuild b/dev-ruby/net-sftp/net-sftp-2.1.2-r2.ebuild
new file mode 100644
index 000000000000..951789a9976a
--- /dev/null
+++ b/dev-ruby/net-sftp/net-sftp-2.1.2-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SFTP in pure Ruby"
+HOMEPAGE="https://github.com/net-ssh/net-sftp"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.13
+ )"