summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/net-ssh-gateway
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/net-ssh-gateway')
-rw-r--r--dev-ruby/net-ssh-gateway/Manifest1
-rw-r--r--dev-ruby/net-ssh-gateway/metadata.xml8
-rw-r--r--dev-ruby/net-ssh-gateway/net-ssh-gateway-1.2.0-r1.ebuild33
-rw-r--r--dev-ruby/net-ssh-gateway/net-ssh-gateway-1.2.0.ebuild33
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/net-ssh-gateway/Manifest b/dev-ruby/net-ssh-gateway/Manifest
new file mode 100644
index 000000000000..2ee04155aa62
--- /dev/null
+++ b/dev-ruby/net-ssh-gateway/Manifest
@@ -0,0 +1 @@
+DIST net-ssh-gateway-1.2.0.gem 23552 SHA256 3e5ab1f9d20e44c838ee890d1ae5c756b4b9cec492bc717340d90869399113db SHA512 d387e7ab709628c79cb0c01d0428a8e7e1beddfbdd14c58b7aaff6de11f4a8a8b2cb2026de95977de830855fbed610c276a52f18469da3b4f11b51885e251f60 WHIRLPOOL f961b541b1764410c94e241f403f4595a3e987cfd76b251e95c4fe12413a84b60fce5d48c9fa4c553e85b9f0535319a7a4d2106cc976185b652b5ad351c8b09b
diff --git a/dev-ruby/net-ssh-gateway/metadata.xml b/dev-ruby/net-ssh-gateway/metadata.xml
new file mode 100644
index 000000000000..6187ddb476d8
--- /dev/null
+++ b/dev-ruby/net-ssh-gateway/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">net-ssh/net-scp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-ssh-gateway/net-ssh-gateway-1.2.0-r1.ebuild b/dev-ruby/net-ssh-gateway/net-ssh-gateway-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..7abc31cdac36
--- /dev/null
+++ b/dev-ruby/net-ssh-gateway/net-ssh-gateway-1.2.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple library to assist in enabling tunneled Net::SSH connections"
+HOMEPAGE="https://github.com/net-ssh/net-scp"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/test-unit:2
+ <dev-ruby/mocha-1"
+
+ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'" test/gateway_test.rb || die
+}
+
+each_ruby_test() {
+ RUBYLIB=lib ruby-ng_testrb-2 test/*
+}
diff --git a/dev-ruby/net-ssh-gateway/net-ssh-gateway-1.2.0.ebuild b/dev-ruby/net-ssh-gateway/net-ssh-gateway-1.2.0.ebuild
new file mode 100644
index 000000000000..c2637ae3f028
--- /dev/null
+++ b/dev-ruby/net-ssh-gateway/net-ssh-gateway-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple library to assist in enabling tunneled Net::SSH connections"
+HOMEPAGE="http://net-ssh.rubyforge.org/gateway"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/test-unit:2
+ <dev-ruby/mocha-1"
+
+ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'" test/gateway_test.rb || die
+}
+
+each_ruby_test() {
+ RUBYLIB=lib ruby-ng_testrb-2 test/*
+}