summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-01 09:53:04 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-02 06:07:34 +0100
commit1832884bea8a429d61dd86e086f8edba0ea02ba8 (patch)
tree5012530a3abe782f2122d14268d92bc8573d698a /dev-ruby/net-telnet
parentsys-apps/sandbox: version bump to 2.29 (diff)
downloadgentoo-1832884bea8a429d61dd86e086f8edba0ea02ba8.tar.gz
gentoo-1832884bea8a429d61dd86e086f8edba0ea02ba8.tar.bz2
gentoo-1832884bea8a429d61dd86e086f8edba0ea02ba8.zip
dev-ruby/net-telnet: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/net-telnet')
-rw-r--r--dev-ruby/net-telnet/net-telnet-0.2.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/net-telnet/net-telnet-0.2.0-r1.ebuild b/dev-ruby/net-telnet/net-telnet-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..24bfd3876fc3
--- /dev/null
+++ b/dev-ruby/net-telnet/net-telnet-0.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="net-telnet.gemspec"
+
+# Don't install the binaries since they don't seem to be intended for
+# general use and they have very generic names leading to collisions,
+# e.g. bug 571186
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides telnet client functionality"
+HOMEPAGE="https://github.com/ruby/net-telnet"
+SRC_URI="https://github.com/ruby/net-telnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}