summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-28 07:30:30 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-28 07:30:30 +0100
commit2c16b938876df1acea2cc68bc70cde33a18a03d2 (patch)
tree7185a3bf1be10fd59982c3674d53b0e9c260813c /dev-ruby/nio4r/nio4r-2.2.0.ebuild
parentdev-perl/Pod-Weaver: Add missing CPAN remote-id's (diff)
downloadgentoo-2c16b938876df1acea2cc68bc70cde33a18a03d2.tar.gz
gentoo-2c16b938876df1acea2cc68bc70cde33a18a03d2.tar.bz2
gentoo-2c16b938876df1acea2cc68bc70cde33a18a03d2.zip
dev-ruby/nio4r: add 2.2.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/nio4r/nio4r-2.2.0.ebuild')
-rw-r--r--dev-ruby/nio4r/nio4r-2.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/nio4r/nio4r-2.2.0.ebuild b/dev-ruby/nio4r/nio4r-2.2.0.ebuild
new file mode 100644
index 000000000000..f3875b6b7916
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-2.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/socketry/nio4r"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc64 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-retry )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/*$(get_modname) lib/ || die
+}