summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-08 06:59:40 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-08 07:48:15 +0200
commitb82cd9ca02b316e96cecb6bac64919331c40b8e9 (patch)
tree6b0a26d485530378cb348e6531af2a39d9d46d6d /dev-ruby/nio4r/nio4r-2.5.3.ebuild
parentdev-ruby/tty-cursor: cleanup (diff)
downloadgentoo-b82cd9ca02b316e96cecb6bac64919331c40b8e9.tar.gz
gentoo-b82cd9ca02b316e96cecb6bac64919331c40b8e9.tar.bz2
gentoo-b82cd9ca02b316e96cecb6bac64919331c40b8e9.zip
dev-ruby/nio4r: add 2.5.3
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/nio4r/nio4r-2.5.3.ebuild')
-rw-r--r--dev-ruby/nio4r/nio4r-2.5.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/nio4r/nio4r-2.5.3.ebuild b/dev-ruby/nio4r/nio4r-2.5.3.ebuild
new file mode 100644
index 000000000000..cf30cac81ab1
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-2.5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/socketry/nio4r"
+
+LICENSE="MIT || ( BSD GPL-2 )"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-retry )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' -e '1irequire "openssl"' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/*$(get_modname) lib/ || die
+}