summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-06 07:46:44 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-06 07:46:44 +0100
commit109e0c3c2f5843560e7415f1ce76f04bdc069e77 (patch)
tree1d939bf8026d84bdd150a19119c717710b85f1a5 /dev-ruby/nio4r
parentapp-misc/yq-2.12.0: Version bump (diff)
downloadgentoo-109e0c3c2f5843560e7415f1ce76f04bdc069e77.tar.gz
gentoo-109e0c3c2f5843560e7415f1ce76f04bdc069e77.tar.bz2
gentoo-109e0c3c2f5843560e7415f1ce76f04bdc069e77.zip
dev-ruby/nio4r: add 2.5.5
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/nio4r')
-rw-r--r--dev-ruby/nio4r/Manifest1
-rw-r--r--dev-ruby/nio4r/nio4r-2.5.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/nio4r/Manifest b/dev-ruby/nio4r/Manifest
index 451e6b3f2232..43255a3babc1 100644
--- a/dev-ruby/nio4r/Manifest
+++ b/dev-ruby/nio4r/Manifest
@@ -1 +1,2 @@
DIST nio4r-2.5.4.gem 110080 BLAKE2B 9aaed6cd4d74cf6ff3fed114d7c0c9162afb646aa6eadf294e0a6710dfca1e6b4ccf1eb8850c8704f3792eb6695034612813db08fbf74814556455db6ab48b4a SHA512 f7e383516ac6b55fd49339280e624a4c35f9cd2d31915b3d117189506522d967fc53a43cde75e8601f3fe0530e1322aeaa8c94a09289ddbefb2afd8d067341ec
+DIST nio4r-2.5.5.gem 121344 BLAKE2B 5e63c528055c4db6b52de7e3f1a0f32aa8b1776d21c303a16030376e1548860a72eae4c2fea09ee5dd458e49e2b4f0da50fe80e4e82f5dbba44b194dce4c35fc SHA512 e0d661b17f44aa5b469061a9b22c1cb565d01d1cf5318e4db39dcc4452bff99774c250853511c2b9742d61ccec123fec76d375069bad74ecb2f411c4495a4121
diff --git a/dev-ruby/nio4r/nio4r-2.5.5.ebuild b/dev-ruby/nio4r/nio4r-2.5.5.ebuild
new file mode 100644
index 000000000000..635dfac5b373
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-2.5.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/socketry/nio4r"
+
+LICENSE="MIT || ( BSD GPL-2 )"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-retry )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' -e '1irequire "openssl"' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/*$(get_modname) lib/ || die
+}