summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-07 09:32:26 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-07 09:32:26 +0100
commit6957bf379c6990d6e7d0cebd949d387bb0c2eb3b (patch)
treeb934c3aa8158a1e15f38cca0bb7e14b114238e5d /dev-ruby/parser/parser-3.0.0.0.ebuild
parentdev-ruby/parser: cleanup (diff)
downloadgentoo-6957bf379c6990d6e7d0cebd949d387bb0c2eb3b.tar.gz
gentoo-6957bf379c6990d6e7d0cebd949d387bb0c2eb3b.tar.bz2
gentoo-6957bf379c6990d6e7d0cebd949d387bb0c2eb3b.zip
dev-ruby/parser: add 3.0.0.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/parser/parser-3.0.0.0.ebuild')
-rw-r--r--dev-ruby/parser/parser-3.0.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/parser/parser-3.0.0.0.ebuild b/dev-ruby/parser/parser-3.0.0.0.ebuild
new file mode 100644
index 000000000000..9fcc1bd5357f
--- /dev/null
+++ b/dev-ruby/parser/parser-3.0.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_VERSION="${PV/_pre/.pre.}"
+
+RUBY_FAKEGEM_GEMSPEC="parser.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A production-ready Ruby parser written in pure Ruby"
+HOMEPAGE="https://github.com/whitequark/parser"
+SRC_URI="https://github.com/whitequark/parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" =dev-util/ragel-6*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/racc )
+ dev-ruby/cliver
+"
+ruby_add_rdepend "=dev-ruby/ast-2.4* >=dev-ruby/ast-2.4.1"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/simplecov/ s:^:#:' test/helper.rb || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake generate || die
+}