summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-16 10:49:15 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-16 10:52:24 +0200
commit2ffd4a6e307b0d913128321b64d162be9c8929fe (patch)
tree0897c2e48a58a8a2b21b49caf3787ba5f2139e79 /dev-ruby/patron
parentdev-ruby/ruby-sdl: cleanup (diff)
downloadgentoo-2ffd4a6e307b0d913128321b64d162be9c8929fe.tar.gz
gentoo-2ffd4a6e307b0d913128321b64d162be9c8929fe.tar.bz2
gentoo-2ffd4a6e307b0d913128321b64d162be9c8929fe.zip
dev-ruby/patron: cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/patron-0.13.3.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/patron/patron-0.13.3.ebuild b/dev-ruby/patron/patron-0.13.3.ebuild
deleted file mode 100644
index cb42adae716b..000000000000
--- a/dev-ruby/patron/patron-0.13.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
-HOMEPAGE="https://toland.github.com/patron/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND+=" net-misc/curl"
-RDEPEND+=" net-misc/curl"
-
-ruby_add_bdepend "test? ( dev-ruby/rack www-servers/puma )"
-
-all_ruby_prepare() {
- # Fix Rakefile
- sed -i -e 's:rake/rdoctask:rdoc/task:' \
- -e 's/README.txt/README.md/' \
- -e '/bundler/I s:^:#:' \
- -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/^end/ s:^:#:' \
- Rakefile || die
-
- # Avoid specs with failures. We were not running any specs before.
- rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/patron extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -Cext/patron V=1
- cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
-}