summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-31 07:00:07 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-31 07:00:07 +0100
commit7e264152d19853baf875bfe2477848bde9abc1be (patch)
tree3f0bd0f1d46d1240edb3280e6a079467acf7f6d0 /dev-ruby/patron
parentx11-drivers/nvidia-drivers: Raise kernel version compatibility. (diff)
downloadgentoo-7e264152d19853baf875bfe2477848bde9abc1be.tar.gz
gentoo-7e264152d19853baf875bfe2477848bde9abc1be.tar.bz2
gentoo-7e264152d19853baf875bfe2477848bde9abc1be.zip
dev-ruby/patron: add 0.11.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/Manifest1
-rw-r--r--dev-ruby/patron/patron-0.11.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
index 7d02beb7f664..9d674e419ead 100644
--- a/dev-ruby/patron/Manifest
+++ b/dev-ruby/patron/Manifest
@@ -1 +1,2 @@
DIST patron-0.10.0.gem 59904 BLAKE2B f4ec8c81e4c0c13f3d3b5e0696955c01c8ff962980a8ed83ca7aaca722c422b0466a806af9b2c36f0183c16767f5b3f37dae4ae4a8801866592c8f861ba9778d SHA512 bfe5fabbcbfa3d1c73ef6f79d100547de7e4121bcbd1f427423a127f0bc698bb8b6ade06c0e2eb1f529d1524e95fc36245b8be9d6e2c12b7e8d18b5f03ae6606
+DIST patron-0.11.1.gem 62976 BLAKE2B fc41865146876129eb824ccdd2351af8f0bb3bf099459becb87d0034291f864d576dda0c0ff017f0147eba88d7592dd5ce8ad3bb926db0d612e522a375a2c31a SHA512 75a5705493f5496928279c751d396f9815bc47b4126ea8f9bcf9cabf7a40219b6f9cc2b12179d79848f616357552edcfe6b2b4312276bece432ed66a94ee8d63
diff --git a/dev-ruby/patron/patron-0.11.1.ebuild b/dev-ruby/patron/patron-0.11.1.ebuild
new file mode 100644
index 000000000000..9d99ba9f6d38
--- /dev/null
+++ b/dev-ruby/patron/patron-0.11.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="https://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}