summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-03-02 07:31:52 +0100
committerHans de Graaff <graaff@gentoo.org>2018-03-02 07:39:11 +0100
commit8094d69bc9d4dc9496f5e559e33f15fe5567797a (patch)
tree62e3fb7b31fb735536a8de0fc0178f4263b1a158 /dev-ruby/patron
parentdev-ruby/ruby-odbc: add 0.99999 (diff)
downloadgentoo-8094d69bc9d4dc9496f5e559e33f15fe5567797a.tar.gz
gentoo-8094d69bc9d4dc9496f5e559e33f15fe5567797a.tar.bz2
gentoo-8094d69bc9d4dc9496f5e559e33f15fe5567797a.zip
dev-ruby/patron: add 0.12.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/Manifest1
-rw-r--r--dev-ruby/patron/patron-0.12.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
index 055fc8c2fb00..4609b195a86b 100644
--- a/dev-ruby/patron/Manifest
+++ b/dev-ruby/patron/Manifest
@@ -1,3 +1,4 @@
DIST patron-0.10.0.gem 59904 BLAKE2B f4ec8c81e4c0c13f3d3b5e0696955c01c8ff962980a8ed83ca7aaca722c422b0466a806af9b2c36f0183c16767f5b3f37dae4ae4a8801866592c8f861ba9778d SHA512 bfe5fabbcbfa3d1c73ef6f79d100547de7e4121bcbd1f427423a127f0bc698bb8b6ade06c0e2eb1f529d1524e95fc36245b8be9d6e2c12b7e8d18b5f03ae6606
DIST patron-0.11.1.gem 62976 BLAKE2B fc41865146876129eb824ccdd2351af8f0bb3bf099459becb87d0034291f864d576dda0c0ff017f0147eba88d7592dd5ce8ad3bb926db0d612e522a375a2c31a SHA512 75a5705493f5496928279c751d396f9815bc47b4126ea8f9bcf9cabf7a40219b6f9cc2b12179d79848f616357552edcfe6b2b4312276bece432ed66a94ee8d63
DIST patron-0.12.0.gem 64000 BLAKE2B 1cdf258f4c49d5da6724a4ccb53ca81dd61f824727b5835a945799722db8aa9dd6878b903ea0cdebb2035a9f20f280539f624b9bf44e9a9da708687b163f8af0 SHA512 1826da20fe4aab21792d189466d4c6385d21388538c46e831f1852e0ea8f4007ddd0221e9c5a04eda67de9212d276bd494a98456f5befef42368925367d58798
+DIST patron-0.12.1.gem 64000 BLAKE2B d30990f79213929494d88e812e9c396474c326e87010a50416400ff5267acd9236fb5aedea8a110338356c3b0debc463752b23a595a04f44d9319a54d1c14cda SHA512 ee551e221ea7c965055ddb72cdd063e5ed476ccaf032bc4b2a7f8344af38a4dbd5942d8eb5710bb2d23ca854b1676ff512eba4bfae7a33deef5238664bc7d00b
diff --git a/dev-ruby/patron/patron-0.12.1.ebuild b/dev-ruby/patron/patron-0.12.1.ebuild
new file mode 100644
index 000000000000..9d99ba9f6d38
--- /dev/null
+++ b/dev-ruby/patron/patron-0.12.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="https://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}