summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-16 19:49:28 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-16 20:32:34 +0200
commit5b31fc5280db49f321756cea6f1abc92d49ca4a7 (patch)
tree1b80074b2a9a73541ff04711b29a4923a0637636 /dev-ruby/pg
parentdev-ruby/pg: Fix USE=doc (diff)
downloadgentoo-5b31fc5280db49f321756cea6f1abc92d49ca4a7.tar.gz
gentoo-5b31fc5280db49f321756cea6f1abc92d49ca4a7.tar.bz2
gentoo-5b31fc5280db49f321756cea6f1abc92d49ca4a7.zip
dev-ruby/pg: add 1.0.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.0.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index 905427ccce7c..e454c180b185 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -1,3 +1,4 @@
DIST pg-0.17.1.gem 142848 BLAKE2B 26715943ffc56d5377613d3dd56bc994696a812ccedf6415233781d6685ac34ddf25321f2f194880dd9df6715d43efef7eaeb00ed8ac594302c6e2e292b07cc8 SHA512 fb637256d084af3b41ba4130f866924df957a63c29d029b99995bf553e545b3d4064e682b00d0604bf495a853a8800b9c8eba34718e96c651c9a697281ae4a62
DIST pg-0.18.4.gem 219648 BLAKE2B f6b957551b0b537dda5551bc8974f5bd2f8a4ee4ecf482a5d3dc3ede0ad610507029693fadbfe9d2e2940f63d82da61e535e802919a82f7e5ea23c1165b81847 SHA512 48e792756c7ee205164b59a9515ace6320150f0ce1907293f8c1a736300c62c0b38c1be49e8ad4f1a50f29abc7f72bb43e742a8e63d9606eff4c7d2191a4fb74
DIST pg-0.21.0.gem 214016 BLAKE2B 9e27646cd85bc97dedfb980f4851b19a1ef2aad17f6a5c60726c1683642af5c4cf87d518b300fb4c894e1580f808f8af6158b57f1ac25971c1fc55818abee6f4 SHA512 590a8c34487d2cf030082cfff87b2cc83b636df06a931e394acfb098ecb5728e793d777f125b036ee9953bbd21ec5facf91c932930acccb507d3394f2fc4cc5b
+DIST pg-1.0.0.gem 213504 BLAKE2B eecaa632c7903f89c503ad92ccff058bbc6c2c80cbf83d656eeb9a5b919b84bb270671ad4e0fa08f55be1bcfc69eb8e13b815c37c601d300de503383f1ba5908 SHA512 1cac025ab8a95b4429534b98377eedeb1e3f8b2c4a859363c4174d477577caf39557b002cde4e745189fa9a29e9181ff9d564d822f15ff5c4f03f7389b0d0398
diff --git a/dev-ruby/pg/pg-1.0.0.ebuild b/dev-ruby/pg/pg-1.0.0.ebuild
new file mode 100644
index 000000000000..dbbd6e9e775f
--- /dev/null
+++ b/dev-ruby/pg/pg-1.0.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="https://bitbucket.org/ged/ruby-pg/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND+=" dev-db/postgresql:*"
+DEPEND+=" dev-db/postgresql
+ test? ( >=dev-db/postgresql-9.4[server,threads] )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/*$(get_libname) lib || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ RSPEC_VERSION=3 ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}