summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-24 07:11:00 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-24 07:11:00 +0200
commit4dfa3546380fdfe9956ef6f4308beef69be8d45e (patch)
tree26b5f29586fa0e6e58e366df66ccc9d9fa343b9e /dev-ruby/pkg-config/pkg-config-1.4.0.ebuild
parentsci-mathematics/gimps: Remove old (diff)
downloadgentoo-4dfa3546380fdfe9956ef6f4308beef69be8d45e.tar.gz
gentoo-4dfa3546380fdfe9956ef6f4308beef69be8d45e.tar.bz2
gentoo-4dfa3546380fdfe9956ef6f4308beef69be8d45e.zip
dev-ruby/pkg-config: add 1.4.0
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.4.0.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.4.0.ebuild b/dev-ruby/pkg-config/pkg-config-1.4.0.ebuild
new file mode 100644
index 000000000000..a8f0cfce739b
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ # drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
+}