summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-27 10:19:09 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-28 06:39:46 +0200
commitb948a09b5cd8aa7c27e6717021f18812772fd67f (patch)
treeeb1a3933c30196f82100146d6866a38de2fcd600 /dev-ruby/pkg-config/pkg-config-1.4.0.ebuild
parentdev-python/libtmux-0.8.2-r2: Revbump, dep on tmux 3 (bug #709834) (diff)
downloadgentoo-b948a09b5cd8aa7c27e6717021f18812772fd67f.tar.gz
gentoo-b948a09b5cd8aa7c27e6717021f18812772fd67f.tar.bz2
gentoo-b948a09b5cd8aa7c27e6717021f18812772fd67f.zip
dev-ruby/pkg-config: cleanup
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.4.0.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.4.0.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.4.0.ebuild b/dev-ruby/pkg-config/pkg-config-1.4.0.ebuild
deleted file mode 100644
index 982645a27694..000000000000
--- a/dev-ruby/pkg-config/pkg-config-1.4.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A pkg-config implementation by Ruby"
-HOMEPAGE="https://github.com/rcairo/pkg-config"
-LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
-# this is used for testing
-DEPEND+=" test? ( x11-libs/cairo )"
-
-all_ruby_prepare() {
- # drop failing tests
- sed -i -e "/test_cflags/,/end/d"\
- -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
-}