summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-31 11:54:22 +0100
committerHans de Graaff <graaff@gentoo.org>2021-10-31 12:35:55 +0100
commitcc86de31c158e4022c64754e55f5e606252f76fa (patch)
tree9740ec198357805a62c0f1bdc9676c3aa3c22324 /dev-ruby/posix-spawn
parentdev-ruby/pg_array_parser: cleanup (diff)
downloadgentoo-cc86de31c158e4022c64754e55f5e606252f76fa.tar.gz
gentoo-cc86de31c158e4022c64754e55f5e606252f76fa.tar.bz2
gentoo-cc86de31c158e4022c64754e55f5e606252f76fa.zip
dev-ruby/posix-spawn: EAPI 8; fix extension install
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/posix-spawn')
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild
new file mode 100644
index 000000000000..61f75a2bf234
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library that implements a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e '/test_backtick_redirect/askip "Output depends on bash version"' test/test_backtick.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
+}