summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/prawn-table
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/prawn-table')
-rw-r--r--dev-ruby/prawn-table/Manifest2
-rw-r--r--dev-ruby/prawn-table/metadata.xml5
-rw-r--r--dev-ruby/prawn-table/prawn-table-0.2.1.ebuild31
-rw-r--r--dev-ruby/prawn-table/prawn-table-0.2.2.ebuild31
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/prawn-table/Manifest b/dev-ruby/prawn-table/Manifest
new file mode 100644
index 000000000000..66d232fb14f6
--- /dev/null
+++ b/dev-ruby/prawn-table/Manifest
@@ -0,0 +1,2 @@
+DIST prawn-table-0.2.1.gem 64000 SHA256 e939e465846fe94ecc6866b4a988ee004dd5bd7ce094d7d0f41e2e5597982584 SHA512 8adfe3a44c95f3bcd8aa12582e2187b66caec2dc41ec13de49004b59c329da3f9d2651e9fbf72c52b0932175a4bdb3f11aece8dfe01a1159de291e53fea36c5c WHIRLPOOL 4c75de771d79f3e0f4b2c85513078022e22170bc4c1ea078cf1a5271d45d9c118b8cb207e0564c591923431a671b604b6841c7e248280ea449f8844afddd4f28
+DIST prawn-table-0.2.2.gem 64512 SHA256 336d46e39e003f77bf973337a958af6a68300b941c85cb22288872dc2b36addb SHA512 9a3c749c27b5588dc1006b952c3f59ad938c05b98575cdd6c6cf6df9fb8acc5a1cebac0e60bbe6252ef2a1df3750f2860338c2234e362ea2c5524a0bd38bb47b WHIRLPOOL b9e0d591c965ec95dbcc6a81cae4c42ae0436d98f17c0e752e6cbda35401d8919c59e175d1d9d8a637062756255325aa4b50654f7bb2f35d02a7e644b8ac8229
diff --git a/dev-ruby/prawn-table/metadata.xml b/dev-ruby/prawn-table/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/prawn-table/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/prawn-table/prawn-table-0.2.1.ebuild b/dev-ruby/prawn-table/prawn-table-0.2.1.ebuild
new file mode 100644
index 000000000000..7c48108fd8d8
--- /dev/null
+++ b/dev-ruby/prawn-table/prawn-table-0.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for tables in Prawn"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+LICENSE="|| ( GPL-2+ Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha
+ >=dev-ruby/pdf-inspector-1.1.0
+ >=dev-ruby/pdf-reader-1.2
+ >=dev-ruby/prawn-1.3.0
+ )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/s/^/#/" spec/spec_helper.rb || die
+ # Remove failing test
+ # See https://github.com/prawnpdf/prawn-table/issues/10
+ sed -i -e "/Prints table on one page when using subtable with colspan > 1/,+24 s/^/#/" spec/table_spec.rb || die
+}
diff --git a/dev-ruby/prawn-table/prawn-table-0.2.2.ebuild b/dev-ruby/prawn-table/prawn-table-0.2.2.ebuild
new file mode 100644
index 000000000000..7c48108fd8d8
--- /dev/null
+++ b/dev-ruby/prawn-table/prawn-table-0.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for tables in Prawn"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+LICENSE="|| ( GPL-2+ Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha
+ >=dev-ruby/pdf-inspector-1.1.0
+ >=dev-ruby/pdf-reader-1.2
+ >=dev-ruby/prawn-1.3.0
+ )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/s/^/#/" spec/spec_helper.rb || die
+ # Remove failing test
+ # See https://github.com/prawnpdf/prawn-table/issues/10
+ sed -i -e "/Prints table on one page when using subtable with colspan > 1/,+24 s/^/#/" spec/table_spec.rb || die
+}