summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/priorityqueue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/priorityqueue')
-rw-r--r--dev-ruby/priorityqueue/Manifest1
-rw-r--r--dev-ruby/priorityqueue/metadata.xml5
-rw-r--r--dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild40
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/priorityqueue/Manifest b/dev-ruby/priorityqueue/Manifest
new file mode 100644
index 000000000000..bcdbab039ac2
--- /dev/null
+++ b/dev-ruby/priorityqueue/Manifest
@@ -0,0 +1 @@
+DIST PriorityQueue-0.1.2.gem 59392 SHA256 3f69849f5db09516fe117b3f98f583ca6fa064f231f83c9ea58a791945dda8f1 SHA512 67ae4507882e7635bef387b0df63ac7724b285cda5e23a06572477de71c98fd10b7718d966f2d5dba1f8cad29df112929d6b0ca30c042c843d364e5c8abccf23 WHIRLPOOL 841b5bee2c172c790c0a2cf65df059ab911dcd09a49722dff0c5ac0aa33349772f7c13ebd266396cc21f925565c9fb50ac08f13bad8d90bb9e6e9f94678e78d7
diff --git a/dev-ruby/priorityqueue/metadata.xml b/dev-ruby/priorityqueue/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/priorityqueue/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild b/dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild
new file mode 100644
index 000000000000..f02846b20739
--- /dev/null
+++ b/dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 -> uses obsolete Config module
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+RUBY_FAKEGEM_NAME="PriorityQueue"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fibonacci-heap priority-queue implementation"
+HOMEPAGE="https://rubygems.org/gems/PriorityQueue"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ rm Makefile *.o *.so || die
+}
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+ cp ext/priority_queue/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/priority_queue_test.rb || die
+}