summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-26 07:21:36 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-26 07:21:36 +0200
commitf01e7fcb0d087ca81feefc14a9d7145403fe3b85 (patch)
tree6d1487e4a7dd7c72e6017cb5d104ca8b90773069 /dev-ruby/pry/pry-0.10.4.ebuild
parentdev-util/cucumber-wire: fix repoman warnings (diff)
downloadgentoo-f01e7fcb0d087ca81feefc14a9d7145403fe3b85.tar.gz
gentoo-f01e7fcb0d087ca81feefc14a9d7145403fe3b85.tar.bz2
gentoo-f01e7fcb0d087ca81feefc14a9d7145403fe3b85.zip
dev-ruby/pry: add 0.10.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/pry/pry-0.10.4.ebuild')
-rw-r--r--dev-ruby/pry/pry-0.10.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/pry/pry-0.10.4.ebuild b/dev-ruby/pry/pry-0.10.4.ebuild
new file mode 100644
index 000000000000..cc8482142c6c
--- /dev/null
+++ b/dev-ruby/pry/pry-0.10.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
+HOMEPAGE="https://github.com/pry/pry/wiki"
+SRC_URI="https://github.com/pry/pry/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="ruby19"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/coderay-1.1.0 =dev-ruby/coderay-1.1*
+ >=dev-ruby/slop-3.4.1:3
+ >=dev-ruby/method_source-0.8.1 =dev-ruby/method_source-0.8*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/open4-1.3
+ >=dev-ruby/rake-0.9
+ >=dev-ruby/mocha-1.0
+ )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on git.
+ # Loosen coderay dependency.
+ sed -e '/git ls-files/d' \
+ -e '/coderay/s/~>/>=/' \
+ -e '/bundler/d' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -e '/[Bb]undler/d' -e "1irequire 'mocha/api'\ " -i spec/helper.rb || die
+ sed -e "1irequire 'ostruct'\ " -i spec/hooks_spec.rb || die
+ sed -e '/of Class after the singleton classes/,+4d' -i spec/method_spec.rb || die
+ # Out of date tests
+ rm spec/commands/gist_spec.rb || die
+}