summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-10-20 07:17:02 +0200
committerHans de Graaff <graaff@gentoo.org>2018-10-20 07:17:02 +0200
commit435ab3af91913ed8a943764695ed6977f5bbd923 (patch)
tree19c81d84fe40001703de80ce64efb7b91d537302 /dev-ruby/psych/psych-3.0.3.ebuild
parentdev-ruby/itextomml: add 1.5.8 (diff)
downloadgentoo-435ab3af91913ed8a943764695ed6977f5bbd923.tar.gz
gentoo-435ab3af91913ed8a943764695ed6977f5bbd923.tar.bz2
gentoo-435ab3af91913ed8a943764695ed6977f5bbd923.zip
dev-ruby/psych: add 3.0.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/psych/psych-3.0.3.ebuild')
-rw-r--r--dev-ruby/psych/psych-3.0.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/psych/psych-3.0.3.ebuild b/dev-ruby/psych/psych-3.0.3.ebuild
new file mode 100644
index 000000000000..8d17eb10b18c
--- /dev/null
+++ b/dev-ruby/psych/psych-3.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A libyaml wrapper for Ruby"
+HOMEPAGE="https://github.com/tenderlove/psych"
+SRC_URI="https://github.com/tenderlove/psych/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" >=dev-libs/libyaml-0.2.1"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "minitest", "~>5.0"' test/psych/helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:test/${PN}:. -e "Dir['test/psych/**/test_*.rb'].each {|f| require f}" || die
+}