summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-23 07:04:22 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-23 07:04:22 +0200
commitf29f386f26063eac69359a354fa9e43c9b63ad9b (patch)
treea14fb60f54e20f6c57ec5d56b14c0ddb930236cc /dev-ruby/pundit/pundit-2.0.0.ebuild
parentdev-python/django-tastypie: remove old (diff)
downloadgentoo-f29f386f26063eac69359a354fa9e43c9b63ad9b.tar.gz
gentoo-f29f386f26063eac69359a354fa9e43c9b63ad9b.tar.bz2
gentoo-f29f386f26063eac69359a354fa9e43c9b63ad9b.zip
dev-ruby/pundit: add 2.0.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/pundit/pundit-2.0.0.ebuild')
-rw-r--r--dev-ruby/pundit/pundit-2.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/pundit/pundit-2.0.0.ebuild b/dev-ruby/pundit/pundit-2.0.0.ebuild
new file mode 100644
index 000000000000..f26d3265c8b5
--- /dev/null
+++ b/dev-ruby/pundit/pundit-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Object oriented authorization for Rails applications"
+HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "test? ( >=dev-ruby/actionpack-3.0.0
+ >=dev-ruby/activemodel-3.0.0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/pry/d" spec/spec_helper.rb || die
+}