summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-01-19 09:01:56 +0100
committerHans de Graaff <graaff@gentoo.org>2019-01-19 09:01:56 +0100
commit3f95500b0509e2afbbd0f468989d6b4f0bbbdc8a (patch)
tree6aa7a905896160e6196edb5ccd959a46a2cdb3ed /dev-ruby/pundit/pundit-2.0.1.ebuild
parentdev-ruby/hitimes: add 1.3.1 (diff)
downloadgentoo-3f95500b0509e2afbbd0f468989d6b4f0bbbdc8a.tar.gz
gentoo-3f95500b0509e2afbbd0f468989d6b4f0bbbdc8a.tar.bz2
gentoo-3f95500b0509e2afbbd0f468989d6b4f0bbbdc8a.zip
dev-ruby/pundit: add 2.0.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/pundit/pundit-2.0.1.ebuild')
-rw-r--r--dev-ruby/pundit/pundit-2.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/pundit/pundit-2.0.1.ebuild b/dev-ruby/pundit/pundit-2.0.1.ebuild
new file mode 100644
index 000000000000..9c4761ec8ec0
--- /dev/null
+++ b/dev-ruby/pundit/pundit-2.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Object oriented authorization for Rails applications"
+HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "test? ( >=dev-ruby/actionpack-3.0.0
+ >=dev-ruby/activemodel-3.0.0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/pry/d" spec/spec_helper.rb || die
+}