summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-07 09:36:29 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-07 09:42:27 -0600
commit222a3d210a394313890cf0d9939dd702df207601 (patch)
treee3d35112e9202c416435cac0f76a6a5bff965031 /dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild
parentapp-admin/augeas: 1.7.0 stable amd64 and x86 (diff)
downloadgentoo-222a3d210a394313890cf0d9939dd702df207601.tar.gz
gentoo-222a3d210a394313890cf0d9939dd702df207601.tar.bz2
gentoo-222a3d210a394313890cf0d9939dd702df207601.zip
dev-ruby/puppetdb-termini: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild')
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild
new file mode 100644
index 000000000000..2cc338be44aa
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/puppetdb/${PN}_${PV}-1puppetlabs1_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}