summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-17 14:41:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-17 14:43:02 -0500
commit8770a6869e9c153db4aea280481df15b62f46bcd (patch)
treec351dc01b9aafda22931323da927b893ff78ba40 /dev-ruby/puppetdb-termini/puppetdb-termini-6.3.1.ebuild
parentapp-admin/puppetdb: 4.3.1 bump (diff)
downloadgentoo-8770a6869e9c153db4aea280481df15b62f46bcd.tar.gz
gentoo-8770a6869e9c153db4aea280481df15b62f46bcd.tar.bz2
gentoo-8770a6869e9c153db4aea280481df15b62f46bcd.zip
dev-ruby/puppetdb-termini: 6.3.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini/puppetdb-termini-6.3.1.ebuild')
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.1.ebuild
new file mode 100644
index 000000000000..6d51b944dfdb
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}