summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-03-11 00:02:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-03-11 00:03:02 -0500
commit42d3339c05e03c6a6939071c7d21ffa656882e53 (patch)
tree2f75dc225d84d5d60152de6076dcb229f96174f2 /dev-ruby/puppetdb-termini
parentapp-admin/puppetserver: 6.9.1 bump (diff)
downloadgentoo-42d3339c05e03c6a6939071c7d21ffa656882e53.tar.gz
gentoo-42d3339c05e03c6a6939071c7d21ffa656882e53.tar.bz2
gentoo-42d3339c05e03c6a6939071c7d21ffa656882e53.zip
dev-ruby/puppetdb-termini: 6.9.1 bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.9.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index f8411ce76642..ad2095ceecb7 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_6.8.0-1stretch_all.deb 21302 BLAKE2B d3524f7acfb60ba73ca5ec42d3d4f2c79efb944ad597e97b664dd7925f24aa80905b2fa7f8dfb98ef7da777242f34d36711affabb179b005703bed8e5d4b33e3 SHA512 8d92e9bffe8e377823b644a54aa73e59c32cf1a69b2b97b9bbf61d9e5149f31c03bb5d39175844f2651a33f6028d44bf0eb6dc2e3ac3236faab9f11a801d4981
DIST puppetdb-termini_6.9.0-1stretch_all.deb 21298 BLAKE2B 98ace25e1768af323beee73b98587921d1880d8af7365401e648ff4db3133bcd3703a356233f03775712aa265e829de6ab5b09f6b02017f833824788bff3dcab SHA512 c74e7d5296c07116d4f95aad24314574a32c8be61d9b53cdb5fddffdc4acc872318b624a6128e61e299e903b864e51217636e3932a931c7c957dd008ad28af57
+DIST puppetdb-termini_6.9.1-1stretch_all.deb 21294 BLAKE2B 579181f4404e5b9dfbc444364c58402135ea68bef0fd3bff894976ee04f7d181699d2456d5ee6105707b765ee1842fac38af7e97f07621436164d79ff8c32a35 SHA512 62d3ac5b922eb3b3ba50f47a104dfb04ca8f3284b2474ed45cf609b21696fa01fa2eaecaa1c94d7b50ac22e8b187b4efc8e43d3cb7d66bf02554b1c03996b040
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.9.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.9.1.ebuild
new file mode 100644
index 000000000000..a7f2b53b2dde
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}