summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-24 10:29:21 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-24 10:30:48 -0500
commit4880d7ab5d678314865222b574f8434ea4d31e0c (patch)
tree50c4298700613e45d8fe9db14f22e1dd63e0f262 /dev-ruby/puppetdb-termini
parentapp-admin/puppetdb: 6.4.0 bump (diff)
downloadgentoo-4880d7ab5d678314865222b574f8434ea4d31e0c.tar.gz
gentoo-4880d7ab5d678314865222b574f8434ea4d31e0c.tar.bz2
gentoo-4880d7ab5d678314865222b574f8434ea4d31e0c.zip
dev-ruby/puppetdb-termini: 6.5.0 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.4.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index d501cb9650d8..7c60810ec5be 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_6.3.2-1stretch_all.deb 20662 BLAKE2B 2e7daef3892070d5356ced070544099a546e4887b5654f795e06952862e4c0cb155df200806217fd5376b1bc3fb53107467ca76acec05283d2f25fed7ca7e5ca SHA512 555abacc9de7221df78a8459a76a4c3c8ce3a1bf5e2b6f1d800761eaea650d2a308e6a5054be082cfb9823903fbe049b2dc5f323b8af93693afbb61c8ce6c4be
DIST puppetdb-termini_6.3.4-1stretch_all.deb 20680 BLAKE2B 41d64eb7a13a0036323b916a70cebdc1d522175e1b6460a0df577b35d57bdfd2eba76784e7af314336d618e7445639e12ec369f243d10b5120ef5006fa21efd3 SHA512 06ce200b4d919d99c28f5361993ca9a641f38d27b1e775db7f1edd10515b75ea131770f3e03a1e3f9d3b32cb8e6f32f6995a6df1e6b3f24d4601585db48a9d8b
+DIST puppetdb-termini_6.4.0-1stretch_all.deb 20680 BLAKE2B ccd129eb8510794c165b6fa88ed391006e583e58fb43fe1be72e1b976d75f30aee0775552f6460840b805e1e4ceb03a6c77dba70afeed75dc2ea3ebcfd4bee77 SHA512 948b5ccd1ddc1f0d52174a073cd13af9e1ba0f713c5326c4d3cbfae7daeeb16cb05efdfb7ac572f9d79e34842fca0a95e054ee49239d593bf4429223c18bb58c
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.4.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.4.0.ebuild
new file mode 100644
index 000000000000..6d51b944dfdb
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}