summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-10-14 14:00:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-10-14 14:01:03 -0500
commitb1784d5148a9cd90425d5a2f09f6da837c132cb5 (patch)
treeee4551400d8600fe2d802960d02805b4504da1b2 /dev-ruby/puppetdb-termini
parentapp-admin/puppetserver: 7.4.1 bump (diff)
downloadgentoo-b1784d5148a9cd90425d5a2f09f6da837c132cb5.tar.gz
gentoo-b1784d5148a9cd90425d5a2f09f6da837c132cb5.tar.bz2
gentoo-b1784d5148a9cd90425d5a2f09f6da837c132cb5.zip
dev-ruby/puppetdb-termini: 7.7.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 8e6803b1249e..3b8d9ad08b5e 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_7.5.0-1stretch_all.deb 21542 BLAKE2B 903a3290f3f10a199d53e5721fdac58aa771b2f9843037250be223df1f4db8328f4164c9f9756013bb5eba81d03fc13ef95b6806f64f6ecd70b7af8aa7336277 SHA512 d6179dbb4192ecfc1d082d32a978bb4d0c89f47db9c335ff70fc75bc81f41e3b0e78fa9fcd80ed3254ce57600e82f75ebefc217069dca8e0ea4014041878052b
DIST puppetdb-termini_7.6.0-1stretch_all.deb 22010 BLAKE2B 535315b0b710fbd0aea5d4fb6964a38300d8da1c723a38153ac011bc326b75eaf9a8abc4804d60d20a078f8aabb01dc674112a0513f90b327dcd13d946cdd4a1 SHA512 cb3ebd4ff35b4b3be57c8a488e66faae1f44d130843cce95033baf3aac70a8519b0f775b3b41991cb5377cc78338141310662ba76a3985d19bcaacf2f7ea9038
+DIST puppetdb-termini_7.7.0-1stretch_all.deb 22018 BLAKE2B 38716d2fe7bbe14656e4f274096ae93d4dc316cbdca49a0da33061df87666caea2bb8fa855de7539be8355805cb5055f74339b12660fe4f8020dbc0f92b79fdf SHA512 61c70aa919a6cee85a36e50c122ed7570e996fb74f68f70733d3f2233dcbbce8623090e9d856722c0da8583836457ded11cd97d1492019a84df00855fe79d462
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild
new file mode 100644
index 000000000000..a7cef96b4b13
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}