summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-25 00:57:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-25 00:57:19 -0500
commitdabdd5c6f31905a697de003f6a65d2ae37ce7c20 (patch)
treee4674956c99b64df710f4469626ccaa8e6fad59b /dev-ruby/puppetdb-termini
parentapp-admin/puppetdb: 7.4.1 bump (diff)
downloadgentoo-dabdd5c6f31905a697de003f6a65d2ae37ce7c20.tar.gz
gentoo-dabdd5c6f31905a697de003f6a65d2ae37ce7c20.tar.bz2
gentoo-dabdd5c6f31905a697de003f6a65d2ae37ce7c20.zip
dev-ruby/puppetdb-termini: 7.4.1 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 3f490d813869..9ca76860cecf 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,3 +1,4 @@
DIST puppetdb-termini_6.13.0-1stretch_all.deb 21296 BLAKE2B 6ef6f82047f293b854e1b0d6db2933e18bc922225d1bb7fe4a3d03d2dbe5da00cdb68e7e3ac35097f466ee21de5a7ed584606684a52c088a9e31abe9fe11d7cf SHA512 bbcf8d2ed996925ead0add6899b266ca9308b01cc12d0dfa6f61956e801a092abf5a01ae4647bf96778f9fe0fa95e17bfae0a3b30576346093651141c1982ebf
DIST puppetdb-termini_7.2.0-1stretch_all.deb 21158 BLAKE2B bb74c11735a557bbee8452f4eb356c1ca038f8cf41bf1b5404f6f204d1d89e8bb532b8a6db8a92ebba9045e744a8a0b68629d60ab295660381a582273a0a67f3 SHA512 6dd4ee1e3d2fd069d5689cbaf0faeb417e5c12bd6d06c721923cbe92b739fa39a658675b40f0474010b3c6a6cabbff8a3fa49f8f79cbcc7bd4fbb1c68b1805f6
DIST puppetdb-termini_7.3.1-1stretch_all.deb 21144 BLAKE2B 34e925a93b9f0c882e051ca0ff4368c06ef2467211e645a976453e60008e1a02ccf76ba8b53270ceba830e43be5d8ababf601c6a5ecad5f9d603dcf56c78e19f SHA512 745cb5fe4eb6e4bb720028f794a767fd7eeb936f310c18f153a94bab28a36e35fc1bd5559b1be20a3ef5573227cbc4f013673eca3d85ff15e8a29d238ffd0370
+DIST puppetdb-termini_7.4.1-1stretch_all.deb 21552 BLAKE2B df93159a7dc9f6a6735f44531306a2b1c7a1bf9d8b88dbd4c9784367e949a83b0cb42dd8172880df9e7f4cbc1d3bcf9da570cdf2fa0437e525452d1f2468551d SHA512 4ffdf5e2019400dbaa5bb1fee22fd66fa430ab395a42d25cca2c61feaf68168b44eb1d29c0a9984a2cb669eff4ffadd9f9c64c6c19ea21bd3ceead392ad6d26b
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild
new file mode 100644
index 000000000000..57a8294eabe9
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}