summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-19 08:06:26 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-19 08:06:26 +0200
commitac8feffa456b17d76fbf0639500ee45283f3e3b9 (patch)
treefd7fb083bbc6e81304d55247433bb254d928c10d /dev-ruby/rack-protection
parentdev-ruby/web-console: cleanup (diff)
downloadgentoo-ac8feffa456b17d76fbf0639500ee45283f3e3b9.tar.gz
gentoo-ac8feffa456b17d76fbf0639500ee45283f3e3b9.tar.bz2
gentoo-ac8feffa456b17d76fbf0639500ee45283f3e3b9.zip
dev-ruby/rack-protection: add 2.1.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.1.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 8386432d8d2f..e359f5b06da9 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1 +1,2 @@
DIST rack-protection-2.0.8.1.gem 16896 BLAKE2B 013fc8a5ceaadbfde52a7aca0dab8116cb01d6f034f3370d22a09545885a61adef92ad5ed9f82faf4434507a079ff9a0c3781b906ab6aba69fa032216f276fcb SHA512 264aef904d9ae1c38197ad4ad44f1638905bd180fc4bb402c47856c37168059e8e975ca2de5518b1e5cebf79b970024b7d9f5f8b8908880451357dea5e428562
+DIST rack-protection-2.1.0.gem 17408 BLAKE2B e4804273d346c76e9e7348bfa9575f16c9d415da9db4e8677782aed70fa613b6f322c82808707734276b8db60fce9d87fbbaac807c1b8df7f6bf1960c76ae244 SHA512 965388584a2cae9065ccc0d041bbd40951f22420f05e657586d710f87ae8f854a0be32c3274b9373f96b5f8eb19354d371e3bce9b2df83c013abfea99f16bded
diff --git a/dev-ruby/rack-protection/rack-protection-2.1.0.ebuild b/dev-ruby/rack-protection/rack-protection-2.1.0.ebuild
new file mode 100644
index 000000000000..06b55d8939fa
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"