summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-06-07 06:35:09 +0200
committerHans de Graaff <graaff@gentoo.org>2018-06-07 06:35:09 +0200
commitc1960acd837e736476aa4d788df06f1074d25cfc (patch)
tree1a642d26c835199fa5bc4672a5cdfc5eafbdaebe /dev-ruby/rack-protection
parentdev-ruby/bunny: add 2.10.0 (diff)
downloadgentoo-c1960acd837e736476aa4d788df06f1074d25cfc.tar.gz
gentoo-c1960acd837e736476aa4d788df06f1074d25cfc.tar.bz2
gentoo-c1960acd837e736476aa4d788df06f1074d25cfc.zip
dev-ruby/rack-protection: add 2.0.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.0.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 3119a3d8763b..734090a5cb04 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,3 +1,4 @@
DIST rack-protection-1.5.3.gem 18432 BLAKE2B 96daf85f6b51b4a8c8992109ccb0821b9f713166965a6d1392f20a966e3502facc4294c0a824beaa395306e0ba3234902eef717ed839e3e3ca907deedf83370d SHA512 9f94f9f25197c3f8227f5c9c9fd2e896e35bfc08d4a20f4dded9c42772f348d16dceda6916429833b498b29c4dbba4dbb31b1a3cf90de597fb6df2de145d655a
DIST rack-protection-2.0.0.gem 15872 BLAKE2B 706fba47a09565bc973a5dbae3369cb26d02839be92347bb153c5f12054ef605e8e025a0666cb0aa44aae316ba494fffdbb7bbc840dfefff9b3e0b0efd39817a SHA512 cce6a8a64c502e4cfec47ae3d76e71aef42b1eec5aa4802a6c443fcb7a8971a99ad9a5b34fea7ae878630faba10d4f5bde4d9a3eb66f63600fcaf02d9ecc0c2e
DIST rack-protection-2.0.1.gem 15872 BLAKE2B bd2b17d21767f4f6772400168ddd53491693780b62359d526739580cca66b5b27d4f4c6f419a6ef695ffbef5ff9045bac683c78117765ff784fda136ec102090 SHA512 6dd525384a0027a1943741881168433c63dc2d18093833dffb3417f3f6ccc46d597435a880d297d07751db1c449f3e37942ae03e33d378dbc74caec38c5cf1df
+DIST rack-protection-2.0.2.gem 16896 BLAKE2B b3ed6a399f93c359a305cef0893bb5056ac26e8d5f345761f497b5eb77aecc201cd388bc0fc021ed039f230bc2ca2348f7eec19aaaac3f2662500bd4c6496a93 SHA512 e74be8b079a1c436d80df2e6bf58dcaea089aceb58b8ec6c08d6ac78b5390bdb1b494d9155350dc7e2639e858209aac10757be54085a565b910e5e74ee882235
diff --git a/dev-ruby/rack-protection/rack-protection-2.0.2.ebuild b/dev-ruby/rack-protection/rack-protection-2.0.2.ebuild
new file mode 100644
index 000000000000..a874a0ed9292
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"