summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-04 06:56:45 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-04 06:59:19 +0200
commit9b8695c7296e33b4884e5de72d250240908aee1e (patch)
tree3c4ededa41a459009dadbd5f84fb4463281fc037 /dev-ruby/rails-dom-testing
parentdev-ruby/rails-deprecated_sanitizer: add ruby24 (diff)
downloadgentoo-9b8695c7296e33b4884e5de72d250240908aee1e.tar.gz
gentoo-9b8695c7296e33b4884e5de72d250240908aee1e.tar.bz2
gentoo-9b8695c7296e33b4884e5de72d250240908aee1e.zip
dev-ruby/rails-dom-testing: add ruby24
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/rails-dom-testing')
-rw-r--r--dev-ruby/rails-dom-testing/rails-dom-testing-1.0.8-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.8-r1.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..fd352258a83e
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/activesupport:4.2
+ >=dev-ruby/nokogiri-1.6.0 =dev-ruby/nokogiri-1*
+ >=dev-ruby/rails-deprecated_sanitizer-1.0.1"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}