summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-24 07:44:29 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-24 07:50:20 +0200
commitafe331f4ebd5b4b1d5865b8d8c0f1f41d061bf88 (patch)
tree11b24342ebc81e293c48637ab61b3a376d494e80 /dev-ruby/rails-html-sanitizer
parentdev-ruby/capybara: amd64 stable (diff)
downloadgentoo-afe331f4ebd5b4b1d5865b8d8c0f1f41d061bf88.tar.gz
gentoo-afe331f4ebd5b4b1d5865b8d8c0f1f41d061bf88.tar.bz2
gentoo-afe331f4ebd5b4b1d5865b8d8c0f1f41d061bf88.zip
dev-ruby/rails-html-sanitizer: add 1.4.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rails-html-sanitizer')
-rw-r--r--dev-ruby/rails-html-sanitizer/Manifest1
-rw-r--r--dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.4.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rails-html-sanitizer/Manifest b/dev-ruby/rails-html-sanitizer/Manifest
index cb0b4792da68..6bf168403213 100644
--- a/dev-ruby/rails-html-sanitizer/Manifest
+++ b/dev-ruby/rails-html-sanitizer/Manifest
@@ -1,2 +1,3 @@
DIST rails-html-sanitizer-1.3.0.gem 16384 BLAKE2B ae0b9acfd4ffc53b84b92cb42c149022312112f90d64866de916be2b91b680ecfbbdc94d278626c992cc90b0061705c11c9a604f6d9e91092e1117e40e003e6d SHA512 01d67f750ffc6ac857e4dc47b77d66e02acc4488f353af97e2fc367590fe85107b631aaf8b32f61f9e1f375c93e1b24fbf966f738e35483f5174880a0ffe5ddb
DIST rails-html-sanitizer-1.4.1.gem 17408 BLAKE2B 4d503bad7a84aefe3bfbb1121eebe768ecf388f502e9ee58f2daf9d1a497ecfea2ad29e7bdd7c2b06e6914355b8eeaf2eeb730aadbceadebdd5a342b9fdc0969 SHA512 c778189fd3fdbdca4a586938d0f22b600f499a174d4d0e34567f0a2a92b8095a2c6c544e47cca3bd7d1f8ae09916898c200d4462de2d31f6bb8eb2c920ab69b4
+DIST rails-html-sanitizer-1.4.2.gem 16896 BLAKE2B 97f09d43ad99c13c07c34c0f5c47e3b34983b94773923cf7d131d1115d818ede619fc0ef268c5523524c53178afde2c9ee2652617add6b4efc282d190591be80 SHA512 9f0872f1000c758918f66a889322d3393ec678604eb3b01fc21bbb861189ec04fcf05f5c9487bd5eeb63ce6d99a80064718c82bfce2daf25c07754979a2ed747
diff --git a/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.4.2.ebuild b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.4.2.ebuild
new file mode 100644
index 000000000000..144833b644b3
--- /dev/null
+++ b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sanitize HTML fragments in Rails applications"
+HOMEPAGE="https://github.com/rafaelfranca/rails-html-sanitizer"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/loofah-2.3:0"
+
+ruby_add_bdepend "test? ( dev-ruby/rails-dom-testing )"
+
+all_ruby_prepare() {
+ # Avoid tests that depend on nokogiri patches to libxml2.
+ sed -i -e '/\(name_action\|attr\)_in_a_tag_in_safe_list_sanitizer/askip "libxml2"' test/sanitizer_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}