summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-20 08:28:36 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-20 09:08:51 +0200
commitfb1a78fcb369fdca6396a4e04ad3237627810e27 (patch)
tree24d53fdaedcd8787d2801f5314562b7ee317c3bd /dev-ruby/rake-compiler/rake-compiler-0.9.2-r1.ebuild
parentdev-ruby/rake-compiler: add 1.0.4 (diff)
downloadgentoo-fb1a78fcb369fdca6396a4e04ad3237627810e27.tar.gz
gentoo-fb1a78fcb369fdca6396a4e04ad3237627810e27.tar.bz2
gentoo-fb1a78fcb369fdca6396a4e04ad3237627810e27.zip
dev-ruby/rake-compiler: cleanup
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/rake-compiler/rake-compiler-0.9.2-r1.ebuild')
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.9.2-r1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.9.2-r1.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.9.2-r1.ebuild
deleted file mode 100644
index 5ddac0620974..000000000000
--- a/dev-ruby/rake-compiler/rake-compiler-0.9.2-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_TEST="none"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
-HOMEPAGE="https://github.com/luislavena/rake-compiler"
-LICENSE="MIT"
-
-SRC_URI="https://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-RUBY_S="luislavena-${PN}-*"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/rake"
-USE_RUBY="ruby19 ruby20" ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
-USE_RUBY="ruby19" ruby_add_bdepend "test? ( dev-util/cucumber )"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19|*jruby)
- # Remove this task so that it won't load on Ruby 1.9 and JRuby
- # that lack the package_task file. It is, though, needed for the
- # tests
- rm tasks/gem.rake || die
- # Remove specs aimed at a C-compiling ruby implementation.
- rm spec/lib/rake/extensiontask_spec.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- # Skip cucumber for jruby (not supported) and ruby20 (not ready yet)
- # Skip rspec as well for ruby21 to allow bootstrapping rspec for ruby21
- case ${RUBY} in
- *ruby19)
- ruby-ng_rspec
- ruby-ng_cucumber
- ;;
- *ruby21)
- ;;
- *ruby22)
- ;;
- *)
- ruby-ng_rspec
- ;;
- esac
-}