summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-02-16 20:18:20 +0100
committerHans de Graaff <graaff@gentoo.org>2016-02-16 20:36:29 +0100
commitb9b667f764a62cfcab25cc972ebe05dbf9473c2c (patch)
treecf5b91f2b63aa7039857a5d855b50a624dea40a3 /dev-ruby/rb-gsl/rb-gsl-1.16.0.6.ebuild
parentdev-ruby/rb-gsl: cleanup (diff)
downloadgentoo-b9b667f764a62cfcab25cc972ebe05dbf9473c2c.tar.gz
gentoo-b9b667f764a62cfcab25cc972ebe05dbf9473c2c.tar.bz2
gentoo-b9b667f764a62cfcab25cc972ebe05dbf9473c2c.zip
dev-ruby/rb-gsl: fix broken narray patch
Rework narray sed script to work with the current version of the extconf.rb script. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/rb-gsl/rb-gsl-1.16.0.6.ebuild')
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-1.16.0.6.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ruby/rb-gsl/rb-gsl-1.16.0.6.ebuild b/dev-ruby/rb-gsl/rb-gsl-1.16.0.6.ebuild
index 1ea156820886..42f79f97cc11 100644
--- a/dev-ruby/rb-gsl/rb-gsl-1.16.0.6.ebuild
+++ b/dev-ruby/rb-gsl/rb-gsl-1.16.0.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
RUBY_FAKEGEM_NAME="gsl"
inherit ruby-fakegem multilib
@@ -28,8 +28,8 @@ RUBY_S="${PN}-${P}"
ruby_add_bdepend "dev-ruby/narray"
ruby_add_rdepend "dev-ruby/narray"
-each_ruby_prepare() {
- sed -i -e '/$CPPFLAGS =/a \$LDFLAGS = " -L#{narray_config} -l:narray.so "+$LDFLAGS' -e 's/src/lib/' ext/gsl_native/extconf.rb || die
+all_ruby_prepare() {
+ sed -i -e '/LOCAL_LIBS/ s: -l: -L#{path.gsub("src", "lib")} -l:' ext/gsl_native/extconf.rb || die
}
each_ruby_configure() {