summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-15 07:53:46 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-15 08:04:08 +0100
commit5df6f9e8c86682d961899c85676db7c4cb213d7d (patch)
treef4c19e9cb5a8428a9425b94cce2d607888082536 /dev-ruby/rb-gsl
parentdev-ruby/classifier-reborn: add 2.2.0 (diff)
downloadgentoo-5df6f9e8c86682d961899c85676db7c4cb213d7d.tar.gz
gentoo-5df6f9e8c86682d961899c85676db7c4cb213d7d.tar.bz2
gentoo-5df6f9e8c86682d961899c85676db7c4cb213d7d.zip
dev-ruby/rb-gsl: fix compilation
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/rb-gsl')
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild b/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
index 9a971a876899..9b2217b37572 100644
--- a/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
+++ b/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
+USE_RUBY="ruby22 ruby23"
RUBY_FAKEGEM_NAME="gsl"
inherit ruby-fakegem multilib
@@ -36,6 +36,7 @@ all_ruby_prepare() {
each_ruby_configure() {
NARRAY=1 ${RUBY} -Cext/gsl_native extconf.rb || die
+ sed -i -e 's:-Wl,--no-undefined::' ext/gsl_native/Makefile || die
}
each_ruby_compile() {