summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-28 08:12:45 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-28 08:32:33 +0200
commit08a81eee95021706cb491a7f9193d26b170d1d90 (patch)
treed4541979bb4429823d198c894c6a1ec30ee75ced /dev-ruby/rb-inotify
parentdev-ruby/instantiator: add ruby25 (diff)
downloadgentoo-08a81eee95021706cb491a7f9193d26b170d1d90.tar.gz
gentoo-08a81eee95021706cb491a7f9193d26b170d1d90.tar.bz2
gentoo-08a81eee95021706cb491a7f9193d26b170d1d90.zip
dev-ruby/rb-inotify: depend directly on ffi and add ruby25
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/rb-inotify')
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..b516935037a8
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}