summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-24 10:02:09 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-24 10:05:48 +0200
commitb78c8b8548d1421dd2c2b22a6f87d3f4a7f9bb93 (patch)
tree6aa2531937ae0d9511d5eb5a8e6f6468e0ffdd72 /dev-ruby/regexp_property_values
parentdev-ruby/redcarpet: add ruby30; fix extension install (diff)
downloadgentoo-b78c8b8548d1421dd2c2b22a6f87d3f4a7f9bb93.tar.gz
gentoo-b78c8b8548d1421dd2c2b22a6f87d3f4a7f9bb93.tar.bz2
gentoo-b78c8b8548d1421dd2c2b22a6f87d3f4a7f9bb93.zip
dev-ruby/regexp_property_values: fix extension install
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/regexp_property_values')
-rw-r--r--dev-ruby/regexp_property_values/regexp_property_values-1.0.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/regexp_property_values/regexp_property_values-1.0.0-r1.ebuild b/dev-ruby/regexp_property_values/regexp_property_values-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..c990f487d2b4
--- /dev/null
+++ b/dev-ruby/regexp_property_values/regexp_property_values-1.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/regexp_property_values/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/regexp_property_values"
+
+inherit ruby-fakegem
+
+DESCRIPTION="See which property values are supported by the regular expression engine"
+HOMEPAGE="https://github.com/janosch-x/regexp_property_values"
+SRC_URI="https://github.com/janosch-x/regexp_property_values/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid dependency on character_set which would lead to circular
+ # dependencies.
+ sed -i -e '/returns a CharacterSet/askip "gentoo circular dependencies"' spec/regexp_property_values/value_spec.rb || die
+}