summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-29 11:18:46 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-29 11:41:54 +0200
commitf335c8b05e861967fe4f66fcff22bb463d2ace54 (patch)
tree7d78799bc57177d1a07038c77b35b1d1cbd46652 /dev-ruby/rex-exploitation
parentdev-ruby/rex-encoder: add ruby24, ruby25 (diff)
downloadgentoo-f335c8b05e861967fe4f66fcff22bb463d2ace54.tar.gz
gentoo-f335c8b05e861967fe4f66fcff22bb463d2ace54.tar.bz2
gentoo-f335c8b05e861967fe4f66fcff22bb463d2ace54.zip
dev-ruby/rex-exploitation: add 0.1.19
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/rex-exploitation')
-rw-r--r--dev-ruby/rex-exploitation/Manifest1
-rw-r--r--dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rex-exploitation/Manifest b/dev-ruby/rex-exploitation/Manifest
index f4674e5a16ac..556516946843 100644
--- a/dev-ruby/rex-exploitation/Manifest
+++ b/dev-ruby/rex-exploitation/Manifest
@@ -1 +1,2 @@
DIST rex-exploitation-0.1.12.gem 78848 BLAKE2B 1c7f2cb6afcf3b7d5911d2e2c9eb8603b5bd484c3948e15ea72c8c1406ec8f968422b40d66ea88678712adce4057a2d847c7baa7972c6a18672765324f3fce31 SHA512 74716b4f23cb490fbc84e37269b12c58ce83ff903cf37b84685bc59838fe6c45f91082db063f9ced5e8270af6b27dad1cc6b836fb470a9a59be7c039f9ed7b2c
+DIST rex-exploitation-0.1.19.gem 79360 BLAKE2B 47043054ee9d08775c67d54b31861ad3a454a487bdc47beb135942e267040de7611308c62a23cbf853d190fb8f88c52998dfe3b24f66a698e76e273b6a69d822 SHA512 244de5259e3f4f645df09d1843c34d9ea4f9ea56ba22498495792f192b79a0451810f5c7e73516da5a455c27e61b66f8ccfbc485372946fcedd179b75ff9b31e
diff --git a/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild b/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild
new file mode 100644
index 000000000000..58d9ec259d80
--- /dev/null
+++ b/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="various helper mechanisms for creating exploits"
+HOMEPAGE="https://rubygems.org/gems/rex-exploitation"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/jsobfu:*
+ dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-encoder
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}