summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-07-29 23:38:57 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-07-30 00:06:48 -0400
commitf704657ad4496be71ad5dba4ce9381cde7d54bf3 (patch)
tree199d8da1649068868a809f90dcc678c5ae1c7ef6 /dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0-r1.ebuild
parentdev-ruby/rex-powershell: drop random bins (diff)
downloadgentoo-f704657ad4496be71ad5dba4ce9381cde7d54bf3.tar.gz
gentoo-f704657ad4496be71ad5dba4ce9381cde7d54bf3.tar.bz2
gentoo-f704657ad4496be71ad5dba4ce9381cde7d54bf3.zip
dev-ruby/rex-random_identifier: drop random bins
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0-r1.ebuild')
-rw-r--r--dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0-r1.ebuild b/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..2745e2b4e614
--- /dev/null
+++ b/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for generating Random identifier strings"
+HOMEPAGE="https://rubygems.org/gems/rex-random_identifier"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# doesn't seem to actually run any tests
+RESTRICT=test
+
+ruby_add_bdepend "dev-ruby/rex-text"